Screenshot of Mountain Lion's Notification Centre

Notification Center icon is top-right

Of course, before hacking your system, make sure you have a proper backup using Time Machine or Carbon Copy Cloner. I’ve had no issues running the commands below on 10.8.1, but you’ve been warned!

Along with the Spotlight Icon, the new Notification Centre that is found in Mountain Lion (OS X 10.8) cannot be removed like other icons in the menubar using Opt+Click/Drag. Instead, users are forced to use crafty coding to overcome the obstacle. On smaller screens, each icon takes up precious screen real-estate. Here are a few methods to over-coming the UI restrictions:

#1 – Hide the icon

To run the following, open up Terminal. Note: You will need to enter in your password…

sudo chmod 600 /System/Library/CoreServices/NotificationCenter.app/Contents/MacOS/NotificationCenter;killall NotificationCenter; killall Dock

The code above restricts directory permissions for the Notification Center, disabling it from being loaded by the OS. It also kills the NotificationCenter process and Dock which automatically reloads. To enable, just run the same command with 777 as so:

sudo chmod 777 /System/Library/CoreServices/NotificationCenter.app/Contents/MacOS/NotificationCenter;killall NotificationCenter; killall Dock

The downside is your System Log will fill up with access denied notifications. Similar code is available for hiding the Spotlight icon without disabling Spotlight (useful if you use Alfred to load apps instead of Spotlight).

sudo chmod 600 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search; killall SystemUIServer

#2 – Kill the process for good

If you don’t plan on using Spolight at all, you can use the following commands in Terminal:

sudo mdutil -a -i off; sudo chmod 600 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search; killall SystemUIServer

To disable the Notification Center:

 sudo launchctl remove com.apple.notificationcenterui.agent

To get Notification Center back:

 sudo launchctl submit -l com.apple.notificationcenterui.agent -p /System/Library/CoreServices/NotificationCenter.app/Contents/MacOS/NotificationCenter

To get Spotlight back:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist; sudo chmod 777 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search; killall SystemUIServer